Jump to content

  • Log in with Facebook Log in with Twitter Log in with Windows Live Log In with Google      Sign In   
  • Create Account

Photo

#define DEFAULT_AXIS_STEPS_PER_UNIT - comment


  • Please log in to reply
1 reply to this topic

#1 dinac

dinac

    Member

  • Members
  • PipPip
  • 61 posts
  • LocationCroatia

Posted 14 May 2013 - 08:43 PM

in everybody configuration.h stays this code :

#define DEFAULT_AXIS_STEPS_PER_UNIT   {78.7402,78.7402,200*8/3,760*1.1}  // default steps per unit for ultimaker

This last Number  760*1.1 gives 836 steps per E

 

I think that beside this code it should be comment that is missing everybody:

 

760*1.1 is for new bolt - think it is v3 version

 

......but many of us that have v2 bolt and made hot bed this is not working good- it shold be 865

 

I think that this must be commented in code, because many that must compile new FW for HOTBED will run in problem of extruding to small amount of filament.....

 

 



#2 gr5

gr5

    Ultimaker User

  • Moderators
  • 5,783 posts
  • LocationBoston
  • Printer(s):UM Original, Ultimaker²

Posted 14 May 2013 - 08:50 PM

It doesn't matter if you use cura as this is ignored.  In all gcode files generated with cura it says (second line of file):

 

M92 E836.000000
 

This M92 E___ command sets the steps/mm.  This line is in EVERY gcode file cura creates.  To set this value, in cura, go to "file" "preferences".